Site errors out after modifying web.config - EventID 8214

Nov 25, 2009 at 10:28 PM

Everytime I try to add the required information to the web.config, my sites error out with the generic "error in Windows Sharepoint Services" message (on the web page). Looking at the event logs on the servers, I see eventID 8214, which I then find out (web searches are my friend) to most people is an issue with the Search Service not using the correct domain service account. I then get led to http://support.microsoft.com/default.aspx/kb/934838/en-us

My questions is how come this only happens wihen I try to "enable" DSRM? When I strip out all mentions of DSRM in my web.config, all my sites work correctly in the farm. I've even tried to minimize the code in web.config to troubleshoot, but to no avail:

		<VisualBranding>
			<RebrandPaths>
				
				<RebrandPath Path="_layouts/" IncludeLayoutsFolder="true" Priority="1" >
					<ApplyMaster File="/_catalogs/masterpage/mymaster.master" />
				</RebrandPath>

			</RebrandPaths>

			<QuerystringBrandings>

				<!--
				<QuerystringBranding Parameter="PrinterFriendly" Value="true" >
					<ApplyMaster File="/_catalogs/masterpage/mymaster.master" />
				</QuerystringBranding>
				-->

			</QuerystringBrandings>

			<BrandingInterceptors>
				<Interceptor Priority="1" Assembly="AKJ.Sharepoint.Branding, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adda199c4fc7387f" Type="AKJ.Sharepoint.Branding.BrandingInterceptor.QuerystringInterceptor" />
				<Interceptor Priority="2" Assembly="AKJ.Sharepoint.Branding, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adda199c4fc7387f" Type="AKJ.Sharepoint.Branding.BrandingInterceptor.RebrandingPathInterceptor" />
			</BrandingInterceptors>

		</VisualBranding>
Any ideas?